Breaking changes

Shopping cart
Back to the start page
We offer a discount of up to 50% on our products!
Shopping cart
Go to content
Support > update

Breaking changes

Please read this if you are on Mac and used AudioUnits. You can ignore it if you used only Vst plugins or if you are on PC.

The AudioUnit interface had to be completely rewritten because of various issues that raised from the introduction of native M1 support and Apple's notarisation. It was not longer possible to keep AudioUnits downward compatible with reasonable effort.
As a result, your old songs that used an previous AU version might 'forget' a couple of patches when you load them with the latest version of a plugin.

What solutions are available?
  • You decide to upgrade later, after you finished the tracks that you are currently working on.
  • You do not upgrade and just stick with your current version.
  • You migrate to the VST version before you upgrade.
  • You write down the names of the patches you used in the tracks. Then you upgrade. After this you re-select the patches and save your song with a new file name.
  • You save patches that you used in the tracks in fxp format from within the plugin. Then you upgrade. After this you load the patches again and save your song with a new file name.

Which plugin versions are affected?
Songs on Mac with VST plugins are not affected.
Songs on Mac with VST3 plugins are not affected.
Songs or plugins on PC are not affected.
Soundsets are not affected.
Single patches (fxp format) are not affected.
Demo versions are not affected.
Electra is not affected.
Gladiator is not affected.
The AudioUnit version of Icarus 2.5.2beta or lower is not compatible with the AudioUnit version of Icarus 2.5.3 (July 2022) or higher.
The AudioUnit version of Saurus 3.3beta or lower is not compatible with the AudioUnit version of Saurus 3.4 (July 2022) or higher.
The AudioUnit version of Nemesis 2.2beta or lower is not compatible with the AudioUnit version of Nemesis 2.3beta (August 2022) or higher.
The AudioUnit version of RayBlaster 2.8beta or lower is not compatible with the AudioUnit version of RayBlaster 2.9 (August 2022) or higher.

What does happen when load a song that contains tracks with an incompatible AudioUnit version?
The wrong patch is selected. But this affects only the track(s) with the incompatible AudioUnit.
You will have to re-select the correct patch and save your song again. Make sure that you use a new file name so that the old one does not get overwritten. You might prefer to keep it as a backup.

How can I check which plugin version I use?
In the plugin click on Help->'show version info' or in Saurus click File->'show version info'.

Download links









Visit us on facebook
Visit us on Twitter
Visit our youtube channel
Contact us by email
View the content of the shopping cart
Back to content